Összes hozzászólás: 219, Új hozzászólások: 0
Lapozás:  [1] 2 3 4 5
 Hozzászóláshoz be kell lépni!
(41847) KiVi
Válasz erre 2017-11-08 20:32:00
Yes, you are right, we will put a notification. You can check our coverage in the online map.
Előzmény (41843) gery 2017-11-07 15:33:10
(41843) gery
Válasz erre 2017-11-07 15:33:10
Hi KiVi,
Thanks for reply. In that case you better should make this clear in your list of downloads. Everything in that entry gives the impression that the map covers all of Germany.
File could e.g. be named 'germany_south_osmand_2.zip' and country you could state 'Germany (southern part)'.
I am wondering if similar for other countries.
(41837) KiVi
Válasz erre 2017-11-04 10:20:30

Unfortunately there is no error with german map, we process only a small souther part of the country. We haven't enough resources for bigger area.

Thanks for your remark, the osmand path was changed.
Előzmény (41828) gery 2017-10-27 14:29:31
(41828) gery
Válasz erre 2017-10-27 14:29:31
OsmAnd map questions:
Your OsmAnd map files look a good deal smaller in size than others, which is nice.
Do you have any info which details were excluded to achieve this? Is it same for all maps or different per country?

I tried your Germany map 'germany_osmand_2.zip' from 2017.10.25. It contains 3 files and I copied all on my phone.
However, the map displays only for the southern part of Germany (try e.g. city Regensburg). It does not work for other parts. E.g., I tried Frankfurt, Berlin, Hamburg, Bonn and none of them works.
I suspect only 1 of the 3 files is good and the others 'broken' in some way.
Can you please check?

I think your Installing instructions at the bottom of page http://openmaps.eu/osmanddownload should be corrected as follows:
  2. Copy the content of the downloaded zip file to the following folder: <SDCard>/Android/data/net.osmand/files
(For example, the map of Hungary sits this way: <SDCard>/Android/data/net.osmand/files/Hungary_openmaps_eu_europe_2.obf)

Thanks & regards
(41791) JHal
Válasz erre 2017-09-26 16:53:14

Currently the path finding options do not seem to be working on the online/desktop map system. The distances seem to be calculated on a straight line between the diffrent way points. See below. Is there soemthing I need to change in my settings to enable this feature again? I have tried both "pedestrian" and "Prefer marked Trails" but seems to make no difference. Thanks!

(40339) davidovits
Válasz erre 2015-12-24 09:19:49
Hi! Use our map? (http://openmaps.eu/mapsforgedownload)
The mapsforge render theme displays correctly in our maps.
Előzmény (40333) ABuster 2015-12-22 20:40:20
(40333) ABuster
Válasz erre 2015-12-22 20:40:20
Hi! I miss the hiking waymarks on my maps (openmaps_5 using on Locus) and also terrain height is show every 100m and not every 10m. Both is shown on the page, I downloaded the theme: http://openmaps.eu/mapsforgetheme

And also I'd like to know, if its possible to show country borders (and inner countries borders). If those 3 things are shown on Locus, your map would be as far as I saw the Vector map/theme, whigh I'd like the most =)

regards and thank you
(39637) peter68
Válasz erre 2015-07-09 12:55:42
This road have a note in OSM database.
"temporary construction. please update status" Because of we don't draw this section.
If the construction will ready, and the note will be delete, we draw the road.

Előzmény (39635) EsArt 2015-07-09 11:27:33
(39635) EsArt
Válasz erre 2015-07-09 11:27:33
error .in one part of the road that does not have drawn there see photo Bregana_Samobor _Croatiaerror .in one part of the road that does not have drawn there see photo Bregana_Samobor _Croatia
(39576) davidovits
Válasz erre 2015-06-25 19:12:28
In new Locus: in one theme folder can have only one XML. Delete the Maryway.xml.
Előzmény (39575) Niana 2015-06-24 15:56:27
(39575) Niana
Válasz erre 2015-06-24 15:56:27
Hi All,

Could you please help me about the installation of theme. I have Locus Pro 3.9.3 and I followed the instruction to install the render themes for Locus, but it isn't in the external themes list. I downloaded some free themes from Locus store, they are working fine.

Thanks in advance,
(38062) KiVi
Válasz erre 2015-01-10 23:09:29
Not here, try this: http://peter68.com/navitel/mapsmser_nup.php Unfortunately hungarian only.
Előzmény (38009) wanek 2015-01-09 22:25:03
(38009) wanek
Válasz erre 2015-01-09 22:25:03

how can i download the navtitel hiking maps for romania ONLY?

(36451) KiVi
Válasz erre 2014-07-19 18:04:36

Try this: http://openmaps.eu/ompbiking You can upload and combine to other maps it with MapSource or BaseCamp .
Have a nice trip!
Előzmény (36450) kostas 2014-07-19 17:52:38
(36450) kostas
Válasz erre 2014-07-19 17:52:38

I will cycle from London to Athens in a few days passing through the following countries, Uk, Belgium, Germany, Austria, Slovakia, Hungary, Serbia, FYROM, Greece.

I bought a Garmin 605 for bicycles and i would like to know if the maps that you offer here will be compatible for my Garmin 605 and whether they are good for cyclists.

Also, the Garmin has a 4GB SD card on it. Will this be enough space to dowload a few map.
(36368) antyinteligent
Válasz erre 2014-07-15 10:49:08

i've to instal these maps [OMP CE (Areas+Routes+Srtm+BHL+THL+TM+BM) OMP CE (Color trail Highlight) OMP Hiking Color Highlight OMP Hiking TrailMarks OMP Romania 3D Openmaps Hiking] on Garmin GPSMap 62s through MapInstaller but i got this exception 0xc0150010 on device 0x77b8482b . I've contacted Garmin and they said it was ptoblem with the coding. Can enyone help with this issue?

PS. When i look at the maps in mapsource its ok, i can choose the layers in the drop down menu, but i don't see the maps in the sidebar.

(36248) peter68
Válasz erre 2014-07-05 08:44:28

In the upper menu line, please find the maps or similar menu.
It is the 7 element from left side.
This menu contains all of installed map. Please choose the Bosnia map from the list.
Előzmény (36242) vlelli 2014-07-04 17:16:27
(36242) vlelli
Válasz erre 2014-07-04 17:16:27
Hi Peter

thanks for your suggestion.
Using bosnia2d.exe and bosnia3d.exe files I was able to install maps on Oregon device,
Some more question:
-  What is the maps resolution (1:25.000 ?)?
- The installation was done, as you suggested, using the install map option in BaseCamp program. I expected to find bosnia maps too in BaseCamp (user data ?), after installation, but I find only previous maps. Any idea?


Előzmény (36241) peter68 2014-07-04 16:12:45
(36241) peter68
Válasz erre 2014-07-04 16:12:45

Please use the Bosnia__ .exe files for install our maps for BaseCamp.
If it was installed, the BaseCamp will show the new maps.

If the BaseCamp detect your Oregon device, please use right click on device name, and choose the map install option.

Előzmény (36240) vlelli 2014-07-04 14:21:12
(36240) vlelli
Válasz erre 2014-07-04 14:21:12
Hi Peter,

I take advantage of you.
I downloaded BaseCamp and Oregon device is detected.
I downloaded bosnia 2d and 3d zip files on my device and I unzipped in two different folders.
Which steps to create the img file and to upload it ? I'm not able to add the folders to 'user data' window in the left side of basecamp window.

Thanks in advance,

Előzmény (36239) peter68 2014-07-04 12:37:50
(36239) peter68
Válasz erre 2014-07-04 12:37:50
Hello Valter,

Please use the Garmin BaseCamp application for the maps transfering.
It is no good way to copy via file manager. The BaseCamp Mapinstall application makes only one img file for the seleceted map items, the Oregon can handle this one img file.


Előzmény (36237) vlelli 2014-07-04 11:05:14
(36237) vlelli
Válasz erre 2014-07-04 11:05:14
Hi all,

I'm new to Garmin.
I'm asking how to install 2D or 3D maps from OpenMaps on Oregon 450t sw version 6.10, equipped with sdcard containing Italy trek map .
When I connect Oregon to my computer (XP SP3) I can browse 2 partitions: internal memory and SDcard.
I read that I simply had to copy maps files on sdcard into the GARMIN folder.
I tried this using Bosnia  3D files ,creating a GARMIN/Bosnia folder where I unzipped .img, .typ and .TDB files.
I was unable to add the new map using Oregon maps menu SETUP>MAP>MAP INFORMATION SELECT MAP (it's non in the available selections)

Where am I wrong ?
Any help is appreciated.


(35951) Lynch
Válasz erre 2014-06-07 14:07:47
David.  Can you please email me: grattanlynch@gmail.com   Thanks
(34299) peter68
Válasz erre 2013-08-31 19:54:33
Hello David.
The map is good selection, but please tell me, what is the zoom level where can not see the trail?
I see the highlight lines from 1.2 km zoom level.
Előzmény (34297) davidt 2013-08-31 16:19:03
(34297) davidt
Válasz erre 2013-08-31 16:19:03
I want to get maps to hike on the Blue Trail in Hungary. I installed Navitel Navigator on my Iphone. Then I downloaded the Hiking Map Hungarybasesrtm_hiking_nm2 into Navitel.

I can see the map but I don't see the trail on the map. What am I doing wrong?



(33881) Trackman
Válasz erre 2013-05-11 11:45:13
Of course, we would thank you very much if wrote some faq.  If it wasn't clear in my previous post our intention is to place your entire faq in our website - not just a link. So please do not use much html formatting but links, ul/ol tags, etc.
Előzmény (33872) vjahns 2013-05-08 22:16:44
(33872) vjahns
Válasz erre 2013-05-08 22:16:44
Let me write something up in the next days, then send a link to the information. If that would be OK with you?
Előzmény (33863) Trackman 2013-05-07 08:57:25
(33863) Trackman
Válasz erre 2013-05-07 08:57:25
Thank you for encouragement.
I was wondering if you'd like to help us to create a faq-like complete web page with these informations.
Előzmény (33862) vjahns 2013-05-06 21:24:03
(33862) vjahns
Válasz erre 2013-05-06 21:24:03
All tools work with wine (http://www.winehq.org/)

Installation Mapsource

Just follow the steps as described below by  (25151) X_roast. The mapsource installation however needs manual intervention as described in the tutorial http://openmtbmap.org/de/tutorials/install-mapsource/.

Run MapSource

To start Mapsource run
wine c:\\program\ files\Garmin\MapSource.exe

The software will be installed in directory $HOME/.wine/drive_c/Program Files/Garmin.
The very first start of Mapsource failed, just start again and it will run.

Installation of Map

To install a map in wine/Garmin, eg. Hungary map,  run
wine Hungary2D.exe

This will copy the map data to the Garmin wine directory ( $HOME/.wine/drive_c/Garmin/Openmaps )

Create GMAPSUPP.IMG for Garmin device

To create a GMAPSUPP.IMG use wine/sendmap20
wine sendmap20.exe

then simply select all IMG files of the map and hit the Button "Create GMAPSUPP.IMG" . Copy the IMG file to MicroSD by UNIX tools (man cp)

Congratulations, the OpenMaps map data are great ! And I am happy because everything I need works in Linux and MacOSX.
Előzmény (33848) Trackman 2013-05-02 19:56:41
(33848) Trackman
Válasz erre 2013-05-02 19:56:41
Hi, we do not support downloading gmapsupp.img file(s) directly because we need to let the user select the areas to upload to gps devices.
But it is possible to create gmapsupp.img from our detailed imgs - at least - with sendmap.
Our imgs are nor corrupted (we're using them on windows) nor encrypted (they are free). We've got no any mac experience, so we can't help why the conversion fails. But googling a bit I've found this page. It states that no conversion is required for BaseCamp for Mac because it can import gmapsupp.img.
Hope, this helps.
Előzmény (33844) vjahns 2013-05-02 15:11:37
(33844) vjahns
Válasz erre 2013-05-02 15:11:37
How would it be possible to install a gmapsupp.img, covering approx. the territories of Austria, Slovakia, Hungary, Croatia and Serbia, on an Garmin Etrex GPS device from OpenMaps maps?

Is there direct download of this file available?

If the gmapsupp.img file must be created, how would I do that with MacOS, Linux or other BSD computer?

So far I downloaded OpenMaps_OmpCEHiking.zip, unzipped and tried to convert to Garmin BaseCamp gmapi. However the conversion fails:
volker@leo:garmin$ ./gmapi-builder/gmapi-builder.py -t OpenMaps/60product.tdb -b OpenMaps/60product.img OpenMaps/*img -o gmapi-out -v -v 2>&1 |less

OpenMaps/05010018.img is not a Garmin IMG file, or it is encrypted.

Any help is much appreciated.
(33201) sw09fl
Válasz erre 2013-02-09 09:59:59
I have drawn Carol’s track (No. 5227) in Romania that she made some notes Roman language. I tried translate and put it on the POIs to map. I would like to send an email to Carol and ask for check my work. Unfortunately this email sending function still not working.
(32806) Trackman
Válasz erre 2012-12-12 23:27:15
hi, I've downloaded your gmasupp.img, renamed to gmapsupp.img and put it on my 60csx. It works well even if I zoom to CU Guanabo Htl Tropicoco.
This img contains an area of our most simple map. So I cannot have any idea why zumo doesn't work with it... :(
Előzmény (32801) miho61 2012-12-12 14:07:44
(32801) miho61
Válasz erre 2012-12-12 14:07:44
hi trackman,

i tested right now: 1 tile from your openmaps.eu (bratislava tile) and 3 tiles cuba (from garmin.openstreetmaps.nl) .
produced with mapsource ONE gmasupp.img, putting it ON garmin zümo, no sdc card in zümo.

Then zooming in in Cuba and when on 120m --> black screen...

the gmasupp.img is 25MB, I put that an www.secit.at/gmasupp.img for downloading if you like to test on your device.
and I put the gpx and gdb file from mapsource  to www.secit.at/121211_miketest.gdb and www.secit.at/121211_miketest.gpx

For the zoom test I use the POI "CU Guanabo Htl Tropicoco"

greets, michael
Előzmény (32800) miho61 2012-12-12 13:16:29
(32800) miho61
Válasz erre 2012-12-12 13:16:29
hi trackman,

thx for your answer. first of all, the link for the other garmin maps is: http://garmin.openstreetmap.nl/ . This site produces on one hand an installable mapsource/basecamp executable and on the other hand an gmasupp.img (and apple stuff). That was meant by "openmaps FREE" :-)

With Cuba I mean that cuba (Fidels or Raouls) south of Florida. So you are right, ther shouldnt be any interference with european tiles...

Just for information: I'll visit cuba next year in february, I've been there last year and it is nearly impossible to drive there without gps. Regular maps I didnt find in Havanna. Last year I used my Android with locus maps, which helped a lot driving there. Besides that the "import" of any GPS device is forbidden, for this time I plan to take my motorbike gps - the zümo- with me, but I try to avoid taking different sdc cards with me. It would not be a problem, having just the original garmin(navtec) maps and the osm of cuba. And of course with a laptop I can manage my garmin device there...

But as I'm really interested, I'll try to produce 2 gmasupp.img, one tile from your openmaps.eu an one tile from cuba from openstreetmap.nl and then I'll test again for black-screen. I think I can reproduce the problem and if, I'll mail you those 2 gmasupp.img - maybe it is reproducable on your garmin device.

what is the concrete product name you're trying to use: installed on my pc is:
OMP-CE (0 lyer, aereas and srtm
OMP-Central Europe 2D and 3D
for the garmin device I just use OMP-Central Europe 3D (without Austria) and all the OMP-CE srtm (Reason is, that as i was motorbiking to Rumania your maps are partially better than the garmins navtec maps :-) And this worked perfectly...

So right now I'll start to produce those 2 small gmasupp.img for testing - I'll inform you bout the result.

And you are perfectly right: contacting garmin is a waste of time :-)

greetings, michael

I dont have any idea if the cgpsmapper is not working well, because using a gmapsupp wich is using your openmaps (3D + srmt), Austria TopoV2 and the original garmin tiles from spain and portugal on the device itself works perfectly. (produced by mapsource).

Előzmény (32793) Trackman 2012-12-11 20:11:09
(32793) Trackman
Válasz erre 2012-12-11 20:11:09
Dear Michael,

thank you for using our products and encouraging us.

Unfortunately, we don't have any zumo to try out this issue.

Anyway, there' are some things in your post that isn't so obvious. Please explain a bit more these things:
- Does cuba mean the country Cuba near the USA? It would be a surprise if our maps and a map of a far country could interfere.
- We have a lot of garmin product - what is the concrete product name you're trying to use? (in mapsource's product selector dropdown)
- What dou you mean when you're talking about "openmaps FREE"?

 "garmin.openmaps.nl" - well, we haven't known about the existence of this site 'til this time...

Garmin index: you may be right. We create our garmin map with cGpsMapper and we don't know too much about it's internal working method or it's problems. It's easy to imagine that cGpsMapper produces such an index that is not working on every garmin device. We're sure that index and searching works at least on gpsmap 6X series. And our users haven't reported "freezed" garmin devices before you.
Contacting garmin: I'm 100% sure they would refuse to help in any way. We tried to report a firmware bug and we include a screenshot in that bug report. Their answer claimed that the source of the problem is an unofficial map loaded into device - but it was very-very clear that the problem isn't related to loaded maps...

So, please tell us more detail - I hope we'll be able to get closer to the solution.

Előzmény (32790) miho61 2012-12-11 17:28:36
(32790) miho61
Válasz erre 2012-12-11 17:28:36
hi folks,
first of all, thank you for the brilliant work.
I've got a problem, which I cannt solve, besides my profession is IT :-) concerning my garmin zümo660

After days of trial i found out, that combining your map with another openstreetmap (cuba) my zümo hangs with black screen, when zooming IN CUBA below 300m (mostly with 129m , at least at 80m) (i didnt test zooming in that combination of openmaps.eu)

lets say, A = cuba, B = openmaps.eu
putting preprepared gmasupp.img  to sdc card and zümo (doesnt matter if A or B on zumo or on sdc) --> black screen
making gmasupp.img A and B via mapsource: same result, black screen
Putting Cuba AND openmaps in ONE gmasupp.img (on sdc or on zümo): --> black screen

ONLY if i produce A and an openmaps.eu FREE second gmasupp.img putting it an zümo and sdc works.

It doesnt make any difference, switching A on and all the rest of maps in zümo off.

my source for the A is garmin.openmaps.nl !

for me it looks like as if an index of openmaps (yours!) is not correctly in the image and the zümo stops, as it is definetely in the combination to different openmaps (cuba and openmaps.eu). I think, that with that combination Ive avoided to have both identical tiles on zümo AND on sdc.
AND: Just ONE tile from openmaps.eu in the gmasupp.img leads to the mentioned effect.

Do you have any idea if that can be solved, besides that I believe I will not be the only with that problem ?
To contact garmin: I dont think it is as software prob of garmin (hopefully) and i dont want to imagine contacting garmin for that problem using two different OSM datas

If you want to test ist, I can putt both gmasupp on my webserver för downloading.

greetings from vienna, Michael
(32040) Guy
Válasz erre 2012-08-24 22:45:23
I want to thank you for your efforts but I will buy the Garmin maps. On my nuvi, if I don't type the country, there is no "region", only "Search all". Since, besides your maps, I must leave the 1,5 Gigs maps of North America - otherwise, I get a "No map data available", - every search takes many minutes and I don't get a list of matches as I type.
So keep up your good work and good luck with the Open maps project.
Előzmény (32030) Trackman 2012-08-24 00:25:00
(32030) Trackman
Válasz erre 2012-08-24 00:25:00
So, you need to search addresses.
First, please notice that we don't (and won't) have house numbers therefore you can search for streets only. And of course, you won't find any streets what aren't there on our maps yet.
As I wrote before we don't have experience with nuvi; but I made some screenshots how street searching works on a 60csx. See them below.
Before trying on nuvi, please double check that all the layers you need are transferred to your gps. You should see Zagreb_areas, Zagreb_routes (and maybe Zagreb_contours and so on) on the Maps tab in MapSource before transmitting to gps if you've selected the map segment that contains Zagreb. The important (searchable) layers ends with "_routes". For making the proper selection this page may help you: http://openmaps.eu/layer_en (Uploading maps to GPS unit)
The base street search screen:

Croatia is the only region uploaded to gps:

Croatia 'region' and Zagreb city is selected:

I've typed an S and the gps showed a street list starting with S from Zagreb:

Found Savska Cesta:
Előzmény (32029) Guy 2012-08-23 17:08:32
(32029) Guy
Válasz erre 2012-08-23 17:08:32
Ok, I have loaded all the maps with most layers (OMP CE (Areas+Routes+BHL+THL+TM+BM). Since I can't change country on the nuvi, how do I find an address in Zagreb ? or Dubrovnik ?
Will I be able to get the information to go to any place in Croatia ?
Thank you
Előzmény (32023) Trackman 2012-08-20 00:30:49
(32023) Trackman
Válasz erre 2012-08-20 00:30:49
Ahh, now it's something new info. You have tried to search something.
Unfortunately, the map you've downloaded is not search capable. Garmin needs some additional index data besides the map data itself to search. The maps divided into countries are our "older" products and they do not support search.
Please, try using our newer products: so-called "layered" products. They aren't divided into countries so you can download whole central europe only from here:
They're support search and they have some nice feature (highlight signed trails, bicycle roads, etc).
Előzmény (32020) Guy 2012-08-19 17:42:09
(32022) Trackman
Válasz erre 2012-08-20 00:19:24
There're big problems around the supporting network of servers (an university is hosting us, so we cannot do too much for bringing network to top shape).
Előzmény (32019) Guy 2012-08-19 04:02:11
(32020) Guy
Válasz erre 2012-08-19 17:42:09
I now have also tried with 2-D and it doesn't work either. In the Maps Info, I still see the Openmaps files and they are checked but Croatia is not known when I try to change country to type an address.
Thank you
Előzmény (32019) Guy 2012-08-19 04:02:11
(32019) Guy
Válasz erre 2012-08-19 04:02:11
I have installed the one in 3-D. Today, I tried many times to download the other one but the server didn't seem to work.
Előzmény (32016) Trackman 2012-08-18 20:42:29
(32016) Trackman
Válasz erre 2012-08-18 20:42:29
Hm, I don't have any experience with nuvi.
Let's try to solve step by step: what exe file have you installed?
This one: http://openmaps.eu/rdl.php?id=HR-3D-exe
or this one: http://openmaps.eu/rdl.php?id=HR-2D-exe ?
Előzmény (31893) Guy 2012-08-18 04:57:38
(31893) Guy
Válasz erre 2012-08-18 04:57:38
I have a Garmin nuvi 295W. I have downloaded the maps for Croatia, I have installed them with MapSource. On the GPS, in Map info, I see the initial CN North America... [1]US & Canada and also OpenMaps [1]Zagreb 3D, North Central Croatia... but I can't see the maps of Croatia, whether the OpenMaps is checked or not.
If only the OpenMaps is checked (I uncheck North Amarica), i get a "no map data available" if I try to type an address.
What can I do ? Thank you.
(27863) Trackman
Válasz erre 2011-08-19 14:26:14
Okay, I'm in a relative new version of mapsource with "OMP Slovenia 2D". The bad new is that this product version is not searchable. So I cannot get into address search menu, it is grayed out.
In other words: in the search menu the first element is unaccessible, only the other two ('find nearest' and 'recently found') are selectable, but these two has no 'state/province' input box. I'm wondering how can you get to the address search dialog while OMP Slovenia 2D product is selected. It seems I havent't really understand yet what problem you have exactly... :)

So, if you need to search in mapsource then you should use so-called 'layered' products. Unfortunately, there's only whole central europe map-set in the layered family, you cannot download an individual country (this is because we don't have enough hw resource to create maps of every version of every country).
Előzmény (27856) Lourens 2011-08-19 09:21:26
(27856) Lourens
Válasz erre 2011-08-19 09:21:26
Mapsource version installed is 6.16.3
a) I 1st downloaded and installed: Slovenia Map installer with land contours (SLO-3D) Garmin 12.4MB 2011.08.10 13:58
b) After that I downloaded and installed: Plain map installer (SLO-2D) Garmin 4.8MB 2011.08.10 13:58
In both cases I experienced the same problem.
Előzmény (27848) Trackman 2011-08-18 22:07:34
(27848) Trackman
Válasz erre 2011-08-18 22:07:34
Dear Lourens,
what mapsource product are you using exactly? (Eg. "OMP Slovenia 2D" or "OMP CE(Areas+Routes" or ...)
What is your mapsource version?
Előzmény (27841) Lourens 2011-08-18 14:18:56
(27841) Lourens
Válasz erre 2011-08-18 14:18:56
I have loaded the Solvenia maps successfully. When I try to put in address information the 1st prompt is 'In what State/provice is the address?'. It does not alow me to enter any information. Am I doing something wrong?

 [1] 2 3 4 5